Fwd: Tacens-Anima ACR3

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: Tacens-Anima ACR3

Narcis Garcia
Hello, I'm trying to check why this supported device does not work with
an Ubuntu 14.04.
Trying to perform the recommended check, I get a strange dependency
requirement:

$ aptitude show libccid | grep -E '(Version:|State:)'
State: installed
Version: 1.4.15-1
$ aptitude show libpcsclite1 | grep -E '(Version:|State:)'
State: installed
Version: 1.8.10-1ubuntu1
$ wget
https://alioth.debian.org/frs/download.php/latestzip/112/ccid-latest.zip
$ unzip ccid-latest.zip
$ tar xjvf ccid-*.tar.bz2
$ cd ccid-*
$ ./configure
ccid-1.4.22/
ccid-1.4.22/NEWS
(...)
checking for ifdhandler.h... no
configure: error: install pcsc-lite 1.8.3 or later, or use ./configure
PCSC_CFLAGS=...


What can I do to this last script detects libpcsclite1 1.8.10 ?
(tested with ccid 1.4.15 too)



-------- Missatge reenviat --------
Assumpte: Re: Tacens-Anima ACR3
Data: Fri, 11 Mar 2016 19:06:06 +0100
De: Ludovic Rousseau <[hidden email]>
A: Narcis Garcia <[hidden email]>

Le 11/03/2016 15:27, Narcis Garcia a écrit :
> Hello,

Hello,

>
> I'm tryng to find how to make work this card device on Ubuntu 14.04;
> http://www.tacens-anima.com/accesories/card-readers/acr3/
>
> I've tried checking described in your page;
> https://pcsclite.alioth.debian.org/ccid.html
>
> BUT:
>
> $ wget
> https://alioth.debian.org/frs/download.php/latestzip/112/ccid-latest.zip
> $ unzip ccid-latest.zip
> $ tar xjvf ccid-*.tar.bz2
> $ cd ccid-*
> $ ./configure

I guess the execution of ./configure failed.
Fix that first.

> $ make
> make: *** No targets specified and no makefile found.  Stop.
> $ sudo ./src/parse > output.txt
> sudo: ./src/parse: command not found
>
> PREVIOUS MATTER:
>
> $ lsusb | grep xpres
> Bus 003 Device 003: ID 048d:1366 Integrated Technology Express, Inc.
> $ pcsc_scan
> PC/SC device scanner
> V 1.4.22 (c) 2001-2011, Ludovic Rousseau <[hidden email]>
> Compiled with PC/SC lite version: 1.8.10
> Using reader plug'n play mechanism
> Scanning present readers...
> Waiting for the first reader...
>
> (no more output)
>


--
Dr. Ludovic Rousseau



_______________________________________________
Pcsclite-muscle mailing list
[hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pcsclite-muscle
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: Tacens-Anima ACR3

Ludovic Rousseau


2016-03-12 10:21 GMT+01:00 Narcis Garcia <[hidden email]>:
Hello, I'm trying to check why this supported device does not work with
an Ubuntu 14.04.
Trying to perform the recommended check, I get a strange dependency
requirement:

$ aptitude show libccid | grep -E '(Version:|State:)'
State: installed
Version: 1.4.15-1
$ aptitude show libpcsclite1 | grep -E '(Version:|State:)'
State: installed
Version: 1.8.10-1ubuntu1
$ wget
https://alioth.debian.org/frs/download.php/latestzip/112/ccid-latest.zip
$ unzip ccid-latest.zip
$ tar xjvf ccid-*.tar.bz2
$ cd ccid-*
$ ./configure
ccid-1.4.22/
ccid-1.4.22/NEWS
(...)
checking for ifdhandler.h... no
configure: error: install pcsc-lite 1.8.3 or later, or use ./configure
PCSC_CFLAGS=...


What can I do to this last script detects libpcsclite1 1.8.10 ?
(tested with ccid 1.4.15 too)

Install the package libpcsclite-dev

Bye

--
 Dr. Ludovic Rousseau

_______________________________________________
Pcsclite-muscle mailing list
[hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pcsclite-muscle