omnikey 3121 and long APDUs

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

omnikey 3121 and long APDUs

Nikos Mavrogiannopoulos
Hi,
 We carry on RHEL a downstream patch for omnikey 3121 to handle long
APDUs, does it make sense to merge that in pcsc-lite-ccid?

https://bugzilla.redhat.com/show_bug.cgi?id=1420024
https://git.centos.org/blob/rpms!pcsc-lite-ccid/4615a1a283618f5357901347aae48c6724572959/SOURCES!ccid-1.4.10-omnikey-3121.patch


regards,
Nikos


_______________________________________________
Pcsclite-muscle mailing list
[hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pcsclite-muscle
Reply | Threaded
Open this post in threaded view
|

Re: omnikey 3121 and long APDUs

Ludovic Rousseau
2017-02-24 11:02 GMT+01:00 Nikos Mavrogiannopoulos <[hidden email]>:
Hi,

Hello,
 
 We carry on RHEL a downstream patch for omnikey 3121 to handle long
APDUs, does it make sense to merge that in pcsc-lite-ccid?

https://bugzilla.redhat.com/show_bug.cgi?id=1420024
https://git.centos.org/blob/rpms!pcsc-lite-ccid/4615a1a283618f5357901347aae48c6724572959/SOURCES!ccid-1.4.10-omnikey-3121.patch

I prefer not to add this patch.
The reader is not CCID compliant and needs special code to support extended APDU.

The OMNIKEY AG CardMan 3121 reader is very old (support was added in CCID version 0.1.0 in August 2003).

Regards,

--
 Dr. Ludovic Rousseau

_______________________________________________
Pcsclite-muscle mailing list
[hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pcsclite-muscle
Reply | Threaded
Open this post in threaded view
|

Re: omnikey 3121 and long APDUs

Nikos Mavrogiannopoulos
On Sun, 2017-02-26 at 16:17 +0100, Ludovic Rousseau wrote:

> 2017-02-24 11:02 GMT+01:00 Nikos Mavrogiannopoulos <[hidden email]>:
> > Hi,
>
> Hello,
>  
> >  We carry on RHEL a downstream patch for omnikey 3121 to handle
> > long
> > APDUs, does it make sense to merge that in pcsc-lite-ccid?
> >
> > https://bugzilla.redhat.com/show_bug.cgi?id=1420024
> > https://git.centos.org/blob/rpms!pcsc-lite-ccid/4615a1a283618f53579
> > 01347aae48c6724572959/SOURCES!ccid-1.4.10-omnikey-3121.patch
>
> I prefer not to add this patch.
> The reader is not CCID compliant and needs special code to support
> extended APDU.
>
> The OMNIKEY AG CardMan 3121 reader is very old (support was added in
> CCID version 0.1.0 in August 2003).

That's correct, on the other hand it is a very common reader found in
many (expected and unexpected) places. We will carry that patch
downstream.

regards,
Nikos


_______________________________________________
Pcsclite-muscle mailing list
[hidden email]
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pcsclite-muscle